OptiFineを導入する際に「有効なModファイルではありません」と言われる

Minecraftは自由度が高い分、リソースパックやModを入れるなど、やりたいことが増えると調べながらの手探り状態になります。
私も未だに手探り状態。今日はこんなエラーに遭遇しました。

Optifineを入れたいのにうまく認識してくれない

Mod読込中に警告発生」「有効なModファイルではありません

何故!?

Minecraftのバージョンや、OptiFineのバージョンを確認しても間違っておらず、OptiFineのバージョンを変えてみても駄目。
原因がさっぱりわからず、右往左往して、ようやく原因が解りました。

 

失敗の原因は、OptiFineをmodsフォルダに入れていたこと

OptiFineは軽量化Modとして有名なのですが、このModと言う単語のままに、modsフォルダにそのままjarファイルを入れて起動していたのですよね。

このファイル、Forgeを使わずに直接使う場合、modsフォルダに入れるのではなく、ダブルクリックで実行して直接MineCraftに導入するものなのです。

ダブルクリックして実行すると、こんな風にインストールが開始されるので、そのままインストールしたらOK

起動時の設定で、バージョンのセレクトボックスに、OptiFineが追加されていたらOKです。

 

今まで複数Modを利用していたため、Forgeを使っており、OptiFine単体での導入は初めてだったので盲点でした。
Forgeを使う場合は、modsフォルダにOptiFineを入れることになります。
複数Modを使う必要のない、軽量化目的のみの建築の場合は、この方法がおすすめです。